Ты меня удивляешь Internet Explorer 8

Ранее не сталкивался с такой ошибкой, поэтому отняла на разгадку минут 30 в первый раз.
Идея состояла в том, что требовалось сверстать проект, который будет поддерживаться от IE9. Проект был успешно выполнен, но после потребовалась поддержка IE8.

Собственно проект сразу отлично работал, кроме одной детали. Деталь заключается в том, что браузер не понимает функцию :last-child. Это показалось мне не бедой, я добавил дополнительно еще и класс и все стало хорошо. Но в другом месте не удавалось решить эту задачу, хотя так же стоял класс. Оказалось дело в том, что пока я не удалил данный параметр, браузер отказывался наотрез и параметры класса хватать, так как столкнулся с незнакомым ему параметром.

last-child в IE8
2014   css   explorer   верстка
Ваш комментарий
адрес не будет опубликован

ХТМЛ не работает

Ctrl + Enter
Популярное